DrayTek device security vulnerability

Incident Report for Onecom Partners

Resolved

Latest information on the third party DrayTek Vulnerability Issue - whilst your services may not currently be impacted, to minimise the risk of downtime, updating your router’s firmware is expected to fix the problem.

Please check, compare and where needed download and install the latest firmware, which can be found by visiting Draytek's official Firmware Download Page to locate updates for the specific model.
Posted Mar 25, 2025 - 09:30 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 24, 2025 - 09:12 GMT

Investigating

Its been brought to our attention that several DrayTek network devices have encountered a severe security vulnerability, causing abnormal Internet connection disruptions for both personal and business users.

To address the issue, DrayTek has released a new firmware update to patch the vulnerabilities. Individual and business users are advised to check their current firmware version and promptly upgrade to the latest version available on the official DrayTek website.
Posted Mar 24, 2025 - 09:12 GMT
This incident affected: Connectivity (Vodafone, BBOne, Other - Legacy).