Services have remained stable overnight following the resolution of the earlier disruption.
If your customers are still experiencing issues, please run diagnostics using the Guided Diagnostics Tool on OneHub, or reach out to our Broadband Support Team for further assistance.
Thank you for your continued patience and understanding while Vodafone worked to resolve the issue.
Posted Oct 14, 2025 - 09:27 BST
Monitoring
Earlier today, we identified an issue affecting Vodafone mobile data and broadband services.
Vodafone engineers are actively working within the core network and are beginning to see positive signs, with some services already restored.
We expect further services to come back online as work progresses throughout the evening.
The situation will be reviewed again tomorrow morning, and we will provide a further update by 9:30 AM.
Thank you for your continued patience and support.
Posted Oct 13, 2025 - 17:29 BST
Update
The issue remains escalated to Vodafone and is under urgent investigation.
We are actively monitoring the situation and will continue to work closely with Vodafone to support a swift resolution.
Our next update will be shared by 5:30 PM, or sooner if new information becomes available.
Thank you for your continued patience and understanding.
Posted Oct 13, 2025 - 16:34 BST
Update
Further to our previous notification, we have been made aware this incident is impacting both Vodafone Connectivity and Mobile Data.
The issue has been escalated to Vodafone for urgent investigation.
We will share a further update by 16:30 PM.
We apologise for any inconvenience this may cause and appreciate your patience.
Posted Oct 13, 2025 - 15:42 BST
Investigating
We’re currently aware of a significant service disruption affecting Vodafone broadband connections. The issue has been escalated to Vodafone for urgent investigation.
We will share a further update by 16:30 PM.
We apologise for any inconvenience this may cause and appreciate your patience.
Posted Oct 13, 2025 - 15:30 BST
This incident affected: Connectivity (Vodafone) and Mobile (Vodafone).