Following a period of monitoring, we are delighted to confirm that this issue has been resolved.
If any users are still having issues, please reboot any affected routers. If problems persist, please escalate through the standard support channels.
We’re grateful for your patience and apologise for any inconvenience caused.
Posted Sep 25, 2025 - 17:26 BST
Monitoring
Vodafone has confirmed that the earlier service disruption has been resolved.
Services are now reported to be restored and stable.
Please advise users to reboot their routers if they are still experiencing issues. If problems persist, escalate through standard support channels.
We’re grateful for your patience and apologise for any inconvenience caused. We will keep this incident for monitoring and confirm once closed.
Posted Sep 25, 2025 - 12:59 BST
Identified
Following our earlier communication, Vodafone has confirmed they are investigating a potential issue with their DNS server, which has been classified as a Priority 1 incident.
We are expecting a further update from them by 2pm.
We are continuing to monitor the situation closely and will keep you informed as soon as we receive more information.
Thank you for your ongoing support and patience.
Posted Sep 25, 2025 - 12:20 BST
Investigating
We are aware of a major service disruption currently affecting Vodafone broadband connections. Several users have reported a total loss of service, and we have escalated the issue to Vodafone for urgent investigation.
We will provide a further update at 12pm
We apologise for any inconvenience this may cause and appreciate your patience