Following a period of close monitoring, we’re pleased to confirm that service levels have returned to normal. Our suppliers have resolved the recent issues that were impacting fault management and order processing.
We apologise for any inconvenience this may have caused
Thank you for your patience and understanding
Posted Nov 26, 2025 - 20:27 GMT
Monitoring
Our suppliers have confirmed that recent issues affecting fault management and order processing across multiple suppliers have been resolved.
We are seeing service levels for fault reporting and order journeys return to normal levels. We continue to actively monitor the situation and will update again should we see any further issues arise.
Thank you for your patience and understanding while this was investigated.
Posted Nov 26, 2025 - 10:24 GMT
Identified
We have been experiencing issues with managing faults and processing orders across multiple suppliers. While services remain operational this may result in delays or disruptions in service resolution and order fulfilment.
Please be assured that we are actively monitoring the situation and will share updates as soon as they become available.
Thank you for your understanding and patience
Posted Nov 25, 2025 - 19:20 GMT
This incident affected: IP Voice (WHC), Connectivity (Vodafone, BBOne), and Fixed Line (WLR).