Vodafone service disruption affecting 4G/5G in the Heathrow area

Incident Report for Onecom Partners

Update

Vodafone have identified the issue and have confirmed the necessary works to resolve the outage will be completed by 02/06/2025 however if we get an update sooner we will keep you posted.
Posted May 23, 2025 - 09:56 BST

Identified

We have received reports from users experiencing issues with their mobile services within the Heathrow area.
Vodafone are aware of an issue and are working to resolve as a priority.
We apologise for any inconvenience, and thank you for your patience.
Further updates will be provided when available
Posted May 22, 2025 - 10:24 BST
This incident affects: Mobile (Vodafone).